Получить код алкогольной продукции из PDF417

Периодически эта функция надобится и периодически я забываю, где она у меня...

 На инфостарте встречается несколько публикаций, в которых получают код в обработке.
Авторы, конечно, не деньги за такое берут,а стартмани.
По-моему, даже стартмани за единственную функцию, пусть и очень нужную - это перебор. Мне кажется, что тем кто скачивает, с большой долей вероятности кроме функции получения кода алкогольной продукции из PDF417 остальная обертка не очень-то и нужна.
Как-то в сердцах я пошел и прокомментировал данные публикации данной функцией и даже вступил в полемику с одним таким "автором". После чего он с помощью модератора почистил нашу переписку.
Я попробовал сделать публикацию с данной функцией туда(на Инфостарт), но она была отвергнута модератором по причине:

"Запрещается под видом статьи выкладывать просто код и краткое пояснение к нему."

Посему выкладываю здесь функцию получения кода алкогольной продукции из PDF417 совершенно безвозмездно.

&НаКлиенте
функция ПолучитьКодАПСКодаМарки(PDF417) ЭКСПОРТ
	итр = 0;
	Значение=СокрЛП(PDF417);
	Если СтрДлина(Значение) <> 68 Тогда 
		
		//Сообщить("Некорректный номер марки") 
		возврат неопределено;
		
	Иначе
		
		если сред(Значение,4,5) = "00000" тогда
			
			Значение = Сред(Значение,9,11);
			итр =11;
			
		иначе
			
			Значение = Сред(Значение,8,12);
			итр =12;
			
		конецЕсли;
		
		Результат=0;
		
		Для Х=1 По итр Цикл
			
			М=1;
			Для У=1 По итр-Х Цикл 
				
				М=М*36 
				
			КонецЦикла;
			
			Результат=Результат+(Найти("0123456789ABCDEFGHIJKLMNOPQRSTUVWXYZ",Сред(Значение,Х,1))-1)*М;
			
		КонецЦикла;
		
		возврат Формат(Результат, "ЧЦ=19; ЧВН=; ЧГ=0");
		
	КонецЕсли;
	
конецФункции

 К сожалению, скоро в ходу станет федеральная марка, которая никак не связана с кодом алкогольной продукции и в таком случае придется переписывать все алгоритмы, завязанные на получение кода АП.

Автоматизация хаоса

Контакты:

Телефон: +7 963 570 26 00

E-mail: al_zzz@mail.ru

Дизайн сайта:

Веб-дизайн и верстка: Зелёнкина Елена

8 963 578 05 35, lena_431@mail.ru