Функция "Вопрос" в интерфейсе Такси.

Согласно новой идеологии от фирмы 1С  для корректной работы вебклиента в барузерах теперь используется интерфейс "Такси". 

Ниже привожу синтаксис функции "Вопрос" для интерфейса такси:

Было 

&НаКлиенте 

Процедура ЗаполнитьТовары(Команда)
  Ответ = Вопрос(“Табличная часть будет очищена. Продолжить?”, РежимДиалогаВопрос.ДаНет);
  Если Ответ = КодВозвратаДиалога.Да Тогда
    //алгоритм заполнения

  КонецЕсли;
КонецПроцедуры

Стало 

&НаКлиенте
Процедура ЗаполнитьТовары(Команда)
  Оповещение = Новый ОписаниеОповещения(“ЗаполнитьТоварыВопросЗавершение”, ЭтотОбъект);
  ТекстВопроса = “Табличная часть будет очищена. Продолжить?”;
  ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьТоварыВопросЗавершение(Результат, ДополнительныеПараметры) Экспорт
  Если Результат = КодВозвратаДиалога.Да Тогда
    //алгоритм заполнения

  КонецЕсли;
КонецПроцедуры


(с) http://курсы-по-1с.рф/news/отказ-от-модальных-окон-в-1с-8-3/

Автоматизация хаоса

Контакты:

Телефон: +7 963 570 26 00

E-mail: al_zzz@mail.ru

Дизайн сайта:

Веб-дизайн и верстка: Зелёнкина Елена

8 963 578 05 35, lena_431@mail.ru