Методика подготовки объекта для работы с печатными формами

  Что бы документ или справочник мог работать с печатными формами – его формы нуждаются в определенного рода доработках.

Поскольку в современных редакциях стандартной подсистемы печати используется программная сборка подменю печати, то важно что бы

1.      В формах (и в форме объекта и в форме списка):

 

1.1   В обработчике «ПриСозданииНаСервере» должен вызывался стандартный алгоритм формирования подменю печатных форм

 

&НаСервере

Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

…

// СтандартныеПодсистемы.Печать

УправлениеПечатью.ПриСозданииНаСервере(ЭтотОбъект, Элементы.ГруппаПечать);

// Конец СтандартныеПодсистемы.Печать

…

КонецПроцедуры

  

1.2   На модуле формы должна присутствовать процедура «Подключаемый_ВыполнитьКомандуПечати» с именно такими названием и текстом:

 

 

В случае формы объекта:

&НаКлиенте

Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

               УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Объект);

КонецПроцедуры

 

Для формы списка:

 

&НаКлиенте

Процедура Подключаемый_ВыполнитьКомандуПечати(Команда)

        УправлениеПечатьюКлиент.ВыполнитьПодключаемуюКомандуПечати(Команда, ЭтотОбъект, Элементы.Список);

КонецПроцедуры

 

 1.3   Среди элементов формы объекта и формы списка должна присутствовать группа типа «Подменю» с названием «ГруппаПечать».

 

 

2.      В модуле менеджера объекта

 

2.1   Должна быть заготовка под процедуру «ДобавитьКомандыПечати»

Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт

 

КонецПроцедуры

   

    2.2   Должна быть заготовка под процедуру «Печать»

 

 

Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

 

КонецПроцедуры

  

3.      В форме списка документа желательно проверить наличие флажка "Использовать всегда" у поля "Ссылка" динамического списка:

 

 
Источник: Курс "Программирование в стандартных типовых решения 8.3" от учебного центра №3.

Автоматизация хаоса

Контакты:

Телефон: +7 963 570 26 00

E-mail: al_zzz@mail.ru

Дизайн сайта:

Веб-дизайн и верстка: Зелёнкина Елена

8 963 578 05 35, lena_431@mail.ru